"The batch callback indicated an error occurred with batch ..."

Topics: Developer Forum, User Forum
Mar 2, 2010 at 2:42 PM
Edited Mar 2, 2010 at 2:44 PM

Hello,

using the adapter I encoutered a problem.
The adapter is configured as shown: http://img35.imageshack.us/img35/9068/62184202.jpg

Configuration of the receive location:
http://img5.imageshack.us/img5/4787/80059590.jpg
http://img525.imageshack.us/img525/1913/79919231.jpg


Via "TCP Client for BizTalk TCP Adapter", I send a message to the configured port. Start and end delimiters are recognized and the message is put into the batch - see lines 31-37 in the application log: http://snipt.org/xlZ

But then, errors follow (as seen in lines 26-28 of the application log):

The method call 'MoveToSuspendQ' threw a COM exception for batch 37239edf-6e64-4a4f-8423-f8ec1f72d248. The details of the exception are: -1061153248: Exception from HRESULT: 0xC0C01620
The batch operation Submit failed with HRESULT -1061154045. Moving the message to the suspend queue.
The batch callback indicated an error occurred with batch 10842597-b119-4b73-8c57-a0a2836347b7, the COM error status is -1061153241


After the 10s time-out, my message is stored in the configured "dead letter folder" - that's it. My BizTalk orchestration doesn't receive the message.

My questions:
What is is the "batch callback" mentioned in line 28 of the application log - and why does that error occur?
What do I have to change to get the TCP message into my orchestration?


Thx a lot
A. Zimmermann