TCPIP Adapter BTS2010

Topics: Developer Forum, Project Management Forum, User Forum
Oct 29, 2010 at 6:14 AM

Hi

I have a customer that is supposed to upgradet to BizTalk Server 2010.  In preparation for that i have tried to install the TCPIP Adapter on that platform without success.

Does anyone know when the adapter will be BTS 2010 Compatible ?

 

Best Regards

Kjartan Halstvedt

Nov 4, 2010 at 8:06 AM

What error did u get? I wanted to try using it with BTS2010. I had to change the launch setup to not check for BizTalk 2009 and then recompiled. The new setup.exe then installed the TCPIP Adapter on BTS2010. I have still to find out whether it still works at runtime. At least it installs now.

Nov 6, 2010 at 9:34 PM

I think that the duplex part of this adapter might not work anymore in BTS2010 because it uses parties and the party management API's have changed in BTS 2010. I have n't tested this yet or looked at the source code to see if it uses these API's but if it does then it will be a bit hard because the new party management API's are not available at the moment.