2
Vote

TcpAdapter Error -HRESULT -1061154045.

description

After a lot of trouble I did get the adapter to work in a development environment. However, now that I moved it to a QA environment (BT servers are grouped with a single SQL database on separate server - but I am only using one of the BT Servers while testing this), the initial testing is failing. The user is sending a single CICS transaction of one record.
 
First error in the Application Event log is: The batch callback indicated an error occurred with batch ..., the COM error status is -1061153241.
Then a warning: The batch operation SubmitRequest failed with HRESULT -1061154045. Moving the message to the suspend queue.
Then a failure to move to the Suspended Queue: The method call 'MoveToSuspendQ' threw a COM exception for batch 9c5a85fb-fa46-4c69-b999-876c94fe97e8. The details of the exception are: -1061153248: Exception from HRESULT: 0xC0C01620.
 
Attached is the trace log and this is the message from the dead messages folder.
USA M 000303014910092007[[[]]000000000000022554 000000000100026 [[[]]000000000000083372 0000000001000 [[[]]

file attachments

comments

CocoaBean wrote Oct 9, 2007 at 3:52 PM

The above error has been occurring consistently since the QA installation, without any successes.
Note that the failure to suspend the message is occurring only with these failures with this adapter. Other issues with other messaging is suspending the messages as normal.

mortenvelling wrote Oct 11, 2011 at 11:46 AM

I'm having the exact same problem it seems. Did you ever manage to figure out a solution? Is it due to the multiserver setup in your QA environment?
Thanks,
Morten

wrote Feb 13, 2013 at 9:10 PM

wrote Apr 27, 2014 at 11:51 PM